DATEDIF - Funktion

(Excel bis 2013)

Mit der DATEDIF Funktion können Sie verschiedene Differenzen zwischen 2 Datumswerten berechnen. Die Funktion hat in Excel ein eigenartig verstecktes Dasein. Sie ist weder im Einfügen/ Funktionen Dialog verfügbar noch wird sie in der Hilfe zu Excel überhaupt erwähnt. Es gibt sie schon seit Excel 5 und vermutlich ist sie auch in zukünftigen Versionen noch verfügbar.

Syntax: = DATEDIF(Startdatum;Enddatum;"Zeiteinheit")

Das Startdatum muss <= dem Enddatum sein, sonst gibt die Funktion einen Fehler zurück.

Die "Zeiteinheit" ist ein Schalter für die zurückzugebende Zeiteinheit. Sie muss in englischen Kürzeln und in Anführungszeichen übergeben werden:

Zeiteinheit

Beschreibung

 y

Anzahl kompletter Jahre
m Anzahl kompletter Monate
d Anzahl der Tage
md Unterschied in Tagen, wobei Monate und Jahre ignoriert werden
ym Unterschied in Monaten, Tage und Jahre bleiben unberücksichtigt
yd Unterschied in Tagen, wobei die Jahre ignoriert werden

Anwendungsbeispiele:

Da die Funktion im Funktionsassistenten nicht verfügbar ist, müssen Sie sie im Bedarfsfall manuell eingeben.

  1. Das Alter in Jahren berechnen

    Das Alter einer Person in Jahren können Sie immer aktuell aus der Differenz des Geburtsdatums zum heutigen Datum unter der Zeiteinheit Jahre berechnen:

    =DATEDIF(A1;HEUTE();"y")
     
  2. oder detaillierter

    =DATEDIF(A1;HEUTE();"y") & " Jahre, " & DATEDIF(A1;HEUTE();"ym") & " Monate, und" & DATEDIF(A1;HEUTE();"md") & " Tage"

    je nach Datum sind das ? Jahre, ? Monate, und ? Tage
     
  3. Tage bis Weihnachten

    =DATEDIF(HEUTE();A2;"d")

    Wenn HEUTE z.B. der 28.12. ist, dann führt diese Funktion zu einem Fehler, da das Startdatum >= dem Enddatum sein muss.

    Dieser Fehler lässt sich abfangen:

    =WENN(ISTFEHLER(DATEDIF(HEUTE();A2;"d"));
    DATEDIF(A2;HEUTE();"d");DATEDIF(HEUTE();A2;"d"))

    Die positiven Tage bis Weihnachten lassen sich natürlich auch ohne DATEDIF über =HEUTE()-A2 berechnen. Doch wird dieses Ergebnis automatisch im Datumsformat dargestellt, das anschließend wieder entfernt werden muss.
     
  4. Wieviel Tage liegen eigentlich zwischen den Geburtstagen von Hugo und Fritz?

 

Neuigkeiten:

  • 07.01.2016

    Duplikate hervorheben
    Excel Add-In - update
    Demoversion und
    Beschreibung hier